• Hallo Besucher!

    Du bist neu im Forum? Dann registriere dich hier, um Diskussionen beizutreten oder eigene Themen zu erstellen. Für die Registrierung ist es erforderlich, dass du einen Spielaccount bei Die Stämme hast.

    Andernfalls kannst du dich hier direkt einloggen.

    Falls du dein Passwort vergessen hast, kannst du hier ein neues Passwort anfordern.

DS obst

DeletedUser71778

Gast
mhmm klingt etz blöd aber was muss ich wie bitte in der unit.config machen? angleichen...... ich verstehe es nicht ganz....... gebe ich dort einfach meine welt ein also bspw: oder wie weiße ich dort meine Welt den einheiten in dieser datei zu? Letzte blöde frage vorerst hoffe ich doch mal ! scheint ja bald behoben zu sein mein fehler!

Code:
$obst_units = array[B](200)[/B];
   
    foreach($obst['[B]200[/B]'] as $world)
    {
        $obst_units[$world] = array([B]200[/B]);
    }
   
    function setUnits($world, $units)
    {
        global $obst_units;
        $obst_units[$world] = $units;
    }
oh man etz fühle ich mich wieder mal dumm :D
 

DeletedUser61508

Gast
Auf dem Server auf dem du spielst gibts laut deinem Bericht 9 verschiedene Einheitentypen, also vermutlich ein Server ohne Bogen und Paladin. Wenn mein Tipp richtig ist, musst du Folgendes in config.units.php einfügen, am besten ab Zeile 64 nachdem $units_std initialisiert wurde:

Code:
setUnits([B]4711[/B], array(
                            new DSUnit('spear', 'Speertr<C3><A4>ger'),
                            new DSUnit('sword', 'Schwertk<C3><A4>mpfer'),
                            new DSUnit('axe', 'Axtk<C3><A4>mpfer'),
                            new DSUnit('spy', 'Sp<C3><A4>her'),
                            new DSUnit('light', 'Leichte Kavallerie'),
                            new DSUnit('heavy', 'Schwere Kavallerie'),
                            new DSUnit('ram', 'Rammbock'),
                            new DSUnit('catapult', 'Katapult'),
                            new DSUnit('snob', 'Adelsgeschlecht')
                        );
4711 solltest du dabei um die Servernummer ersetzen für welche du OBST benutzen willst bzw. welche in der config.inc.php unter $obst['worlds'] eingetragen ist.

EDIT: Ach ja, die 200'er in deinem Code machen keinen Sinn. Die haben da nichts zu suchen.
 

DeletedUser71778

Gast
Auf dem Server auf dem du spielst gibts laut deinem Bericht 9 verschiedene Einheitentypen, also vermutlich ein Server ohne Bogen und Paladin. Wenn mein Tipp richtig ist, musst du Folgendes in config.units.php einfügen, am besten ab Zeile 64 nachdem $units_std initialisiert wurde:

Code:
setUnits([B]4711[/B], array(
                            new DSUnit('spear', 'Speertr<C3><A4>ger'),
                            new DSUnit('sword', 'Schwertk<C3><A4>mpfer'),
                            new DSUnit('axe', 'Axtk<C3><A4>mpfer'),
                            new DSUnit('spy', 'Sp<C3><A4>her'),
                            new DSUnit('light', 'Leichte Kavallerie'),
                            new DSUnit('heavy', 'Schwere Kavallerie'),
                            new DSUnit('ram', 'Rammbock'),
                            new DSUnit('catapult', 'Katapult'),
                            new DSUnit('snob', 'Adelsgeschlecht')
                        );
4711 solltest du dabei um die Servernummer ersetzen für welche du OBST benutzen willst bzw. welche in der config.inc.php unter $obst['worlds'] eingetragen ist.

EDIT: Ach ja, die 200'er in deinem Code machen keinen Sinn. Die haben da nichts zu suchen.
Mega vielen lieben dank!!!!!
 

DeletedUser71778

Gast
Super

Danke an alle die geholfen haben mega gut endlich funktioniert und was ist es gewesen nutzer fehler Propgramm TOP MEGA ich freue mich so!

Ihr glaubt gar nicht wie lange ich mir das OBST tool schon wirklich gewünscht habe, aber nie lust und muse als nix webspace nutzer da rein zu arbeiten aber eh danke mega gut!!!!


Letzte 10...
Alle Berichte
Bericht einlesen
Suche
Suche Zustimmung
Gruppe: keine Gruppe
Welt: 101
Eingelesen von: Sunchy
Eingelesen am: 15.03.2014, 16:34
Diesen Bericht löschen
Diesen Bericht in die Gruppe einordnen
Diesen Bericht der Welt zuordnen
 
Reaktionspunktzahl
2
Mhm...Kompabilität zu neuen PHP Versionen wär mal toll, alle Deprecated Fehler auszubessern ist ne harte Arbeit...
 

DeletedUser150218

Gast
in der ajax.php wird mit $_POST gearbeitet, das Userscript sendet die Daten jedoch per $_GET
 

DeletedUser61508

Gast
in der ajax.php wird mit $_POST gearbeitet, das Userscript sendet die Daten jedoch per $_GET
Im Thread zu dem Script gibts nach meiner Erinnerung einen Beitrag von meiner Wenigkeit, in der eine aktuelle Version der ajax.php verlinkt ist die auch mit $_GET arbeitet. Irgendwann vor längerer Zeit wurde das mal notwendig, weil das Script in seiner ursprünglichen Form verboten werden sollte und ich eine Alternative zur damaligen Art Berichte zu senden brauchte.

EDIT Hier noch der erwähnte Beitrag: http://forum.die-staemme.de/showthr...erver-senden&p=3727506&viewfull=1#post3727506
 
Zuletzt bearbeitet von einem Moderator:

DeletedUser96154

Gast
gibt es das Tool noch? kann man es noch irgendwo downloaden?
 

Eroberer der Welt

Gast
gibt es das Tool noch? kann man es noch irgendwo downloaden?
Offiziell wohl nicht mehr. Auch Nussi13 ist inaktiv (Letzte Aktivität 08.04.14 09:45).

Ich habe bei Google noch das hier gefunden: Download-Link
Ich weiß aber nicht, ob das noch irgendwie funktioniert oder sonst was. Quelle: https://github.com/sgustav/ds-obst

Sonst habe ich noch diese Seite gefunden: http://sourceforge.net/projects/obst-ab/

Aber eine aktuell Version gibt es wohl nicht mehr.
 
Zuletzt bearbeitet von einem Moderator:

DeletedUser96154

Gast
ok danke!

schade, dann versuche ich ne ältere version zum laufen zu bringen
 

Lord Nelsson

Gast
Neue Version

Kennt sich irgendwer hier mit PHP aus und könnte mir sagen, wie ich OBST die neue Berichteformatierung einlesen lassen kann?
Wäre echt nett, wenn jemand antworten würde.
Felix der Feldherr hat es jetzt schon auf einem Server installiert, nur lassen sich die Berichte wegen irgendeiner Änderung nicht einlesen.

MfG

Lord Nelsson
 

DeletedUser131797

Gast
Download fehler

Hallo,

habe intresse an der Nutzung, beim runterladen erscheint aber dieser Fehler:

Forbidden

You don't have permission to access /OBST-download/index.php on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Apache Server at www.voecklataler-pass.at Port 80


was mache ich Falsch??

Mein Rechner ist ein 8.1 Windows Laptop - Greasmonkey ist installiert und ich nutze mehrere Skripte seit Jahren Problemlos - eben falls nutze ich Workbennch

BTW. schönen Gruß an Torridity
 
Zuletzt bearbeitet von einem Moderator:

DeletedUser61508

Gast
Danke, Gruß zurück. :)

Du machst nichts falsch, der Download ist schlicht und ergreifend nicht mehr verfügbar bzw. nicht zugreifbar. Da hilft nur sich per Mail an den Autor zu wenden (Adresse hat er ja angegeben) und zu hoffen, dass er seine Mails ab und zu noch liest.

Ansonsten gibts eine sehr alte OBST Version hier:

http://obst-ab.sourceforge.net/obst.html

und eine Neuere hier:

https://github.com/Sinnohd/ds-obst

Darüber hinaus sollte es möglich sein, irgendeine laufende Installationen zu kopieren und woanders zu verwenden. Ist natürlich mehr als unsauber und eigentlich nicht im Sinne der Entwickler, aber was soll man machen!? Sollte kein Feedback vom Entwickler kommen meld dich einfach mal per PN, ich hab noch ne Installation der letzten Version rumliegen.
 

DeletedUser131797

Gast
Danke dir!!

Wobei - scheint ja nicht mehr zu funtzen - kann ich so was ähnliches i.w. anders machen, ev. WB
 
Zuletzt bearbeitet von einem Moderator:

Eroberer der Welt

Gast
Da es inzwischen nicht einmal mehr die Domain des angegebenen Downloadlink gibt, sollte man das Tool vielleicht mal aus der Scriptdatenbank entfernen. Wirkt schon komisch, wenn man auf den Link klickt und einem dann angeboten wird, die Domain zu kaufen.^^

Hat eigentlich mal jemand versucht, den Autor via E-Mail zu erreichen?


PS: Wenn der Post nicht erwünscht ist, bitte kurze PN an mich. Danke!
 

DeletedUser144697

Gast
Da es inzwischen nicht einmal mehr die Domain des angegebenen Downloadlink gibt, sollte man das Tool vielleicht mal aus der Scriptdatenbank entfernen. Wirkt schon komisch, wenn man auf den Link klickt und einem dann angeboten wird, die Domain zu kaufen.^^

Hat eigentlich mal jemand versucht, den Autor via E-Mail zu erreichen?


PS: Wenn der Post nicht erwünscht ist, bitte kurze PN an mich. Danke!
Hallo Eroberer der Welt,
ja ich habe ihn vorhin angeschrieben da ich ihn fragte ob es nocht weiter entwickelt werde.
Sobald ich eine Antwort bekomme sage ich hier bescheied.
Mit freundlichen Grüßen,
Lukas aka. gobi1
 

DeletedUser144697

Gast
Hallo habe eine Narricht bekommen :)

Dies schrieb er:
Hallo Lukas,

danke erstmal für die lieben Worte über meine Tools. :)

Zu DS OBST: Ich habe DS OBST schon seit vielen Jahren aufgegeben. Das Projekt wurde dann von einigen anderen Entwicklern weiter betreut, die immer mal wieder kleinere Updates vorgenommen haben. Heute gibt es die aktuellste Version von DS OBST mit all diesen Updates auf Github, z.B. hier:
https://github.com/rsnitsch/ds-obst
Oder hier:
https://github.com/sgustav/ds-obst

Zu DS NoPaste: Um dieses Projekt kümmere ich mich noch selbst. Leider wurde vor einiger Zeit das Einlese-Skript für die Farmberichte verboten. Ansonsten sollte die Webseite aber problemlos funktionieren.

Und fragte ob ich es auch weiter entwickeln darf da schrieb er folgendes:

Hallo Lukas,

ihr dürft DS OBST selbstverständlich nach Belieben weiterführen. Es ist ja sowieso opensource (!).


LG
Lukas
 
Reaktionspunktzahl
391
Hallo:)
Ich weiß nicht ob sich noch irgendwer um DS Obst kümmert, wäre auf jedenfall geil.
Auf jedenfall habe ich jetzt die neueste Version von https://github.com/sgustav/ds-obst runtergeladen und installiert. Funktioniert auch soweit alles, das ist also kein Problem.
Wenn ich aber die Hauptfunktion - also Berichte einlesen - nutzen möchte gibt er mir die folgende Fehlermeldung raus:
Der Bericht konnte nicht eingelesen werden! Möglicherweise musst du eine neue Version von OBST installieren!
Dazu oben, halb verdeckt von den Buttons die Notiz:
Notice: there have to be 4 troop sets and 10 types of units! not more, not less! found: 12 in /DS_Obst/obst-ab/include/class.dsBericht.php on line 494.
In ebend dieser Zeile ist allerdings nur diese Fehlermeldung festgehalten, leider nicht der Code so das man da evtl. etwas einstellen könnte.
Zeile 494 schrieb:
trigger_error('there have to be 4 troop sets and 10 types of units! not more, not less! found: '.count($this->matches));
Wenn sich also noch jemand damit beschäftigt und mir hierbei helfen könnte, würde ich mich über eine Antwort freuen.
Liebe Grüße Marvin