• Hallo Besucher!

    Du bist neu im Forum? Dann registriere dich hier, um Diskussionen beizutreten oder eigene Themen zu erstellen. Für die Registrierung ist es erforderlich, dass du einen Spielaccount bei Die Stämme hast.

    Andernfalls kannst du dich hier direkt einloggen.

    Falls du dein Passwort vergessen hast, kannst du hier ein neues Passwort anfordern.

Script API

Antimacht

Community-Management
Reaktionspunktzahl
1.347
Liebe Community,

um die Spieler schnell und einfach auf ein nicht mehr funktionierendes Script hinweisen zu können, muss in jedem Script eine Script API eingebaut sein. Damit können im Falle von Kompabilitätsproblemen, die durch Updates oder andere Umstellungen auftreten können, alle Script-User schnell und einfach auf diese hingewiesen werden.

Deshalb müssen alle Scripte mit der Script API arbeiten. Für die Script-Autoren bedeutet dies, dass ihr einen einfachen Funktionsaufruf am Anfang des Scripts einbaut. Diese Funktion erfordert vier Parameter:
  • String: Name des Scripts (bitte benutzt einen beschreibenden Namen)
  • Boolean: Version ist kompatibel (= true)
  • String: Name des Script-Autors
  • String: E-Mail des Script-Autors; optional, alternativ kann als Verweis ans Forum folgende Fake-Adresse eingetragen werden:
    Code:
    support-nur-im-forum@die-staemme.de
Was macht die Funktion?
Wenn wir feststellen, dass ein Script nicht kompatibel mit der aktuellen Spielversion ist, stoppen wir die Ausführung des Scripts, geben eine Fehlermeldung aus und zeigen die Kontaktdaten des Script-Autors an. Dies kann ohne großen Mehraufwand für den Autor in alle Scripte integriert werden. Wir, als Stämme-Team, ändern in diesem Fall nur den Boolean auf "false", wodurch dem Script-Nutzer eine entsprechende Fehlermeldung ausgegeben wird. Bitte beachtet, dass die Aktualisierung des Scripts in weiterer Folge nach wie vor Aufgabe des Script-Autors ist.

Der Funktionsaufruf für Schnellleistenscripte sieht dann so aus:
Code:
ScriptAPI.register( 'Beispielscript', true, 'Max Mustermann', 'support-nur-im-forum@die-staemme.de' );
Um den Funktionsaufruf für Userscripte richtig einzustellen, muss man etwas tiefer in die Trickkiste greifen. Auf die API kann hier nur durch die Benutzung des window- (Opera) oder unsafeWindow-Objekts (Firefox) zugegriffen werden. Eine mit beiden Browsern kompatible Lösung könnte so aussehen:
Code:
var api = typeof unsafeWindow != 'undefined' ? unsafeWindow.ScriptAPI : window.ScriptAPI;
api.register( 'Beispielscript', true, 'Max Mustermann', 'support-nur-im-forum@die-staemme.de' );
Durch die Verwendung der API in allen Scripten kann gerade die Vielzahl an Anfragen, die wir aufgrund von nicht funktionalen Scripten erhalten, sehr stark reduziert werden. Denkt also daran, dass Ihr eure Scripte immer aktuell haltet, um ohne Unterbrechungen spielen zu können.

Viele Grüße
Euer Stämme-Team