• Hallo Besucher!

    Du bist neu im Forum? Dann registriere dich hier, um Diskussionen beizutreten oder eigene Themen zu erstellen. Für die Registrierung ist es erforderlich, dass du einen Spielaccount bei Die Stämme hast.

    Andernfalls kannst du dich hier direkt einloggen.

    Falls du dein Passwort vergessen hast, kannst du hier ein neues Passwort anfordern.

Java ist doof !

Schönen Abend,

ich hatte schon immer Probleme mit diesem "tollen" Programm, nur inzwischen nervt es einfach nurnoch ...
Ich krieg es einfach nicht hin Java ganz normal auf den Rechner zu ziehen ohne das es irgendwelche Probleme gibt -.-

Ich habe Windows 7 und ein 64Bit System.

Java 8 64Bit hab ich schon geladen, das wird aber von vielen Seiten nicht erkannt.
Wenn ich auf java.com mir die neuste Version hole, erscheint mitten in der Installation: "Java could not create any virtual machine !"

Wollte das aktuellste Workbench laden, dessen Installation /Exe oder Zip ging einfach nicht da Java anscheinend fehlt wenn ich nur das 8er Update draufhabe. Wenn ich das neuste Installiere kommt wieder das Virtual Machine Geschwätz ...

Hoffe jemand kann mir helfen der das selbe Problem hatte, oder sich auskennt.

Vielen Dank !
 

roxxstar

Gast
versuchs mal im workbench forum, bei mir gings dswb übrigens nur mit ner älteren version von java und auch nur mit ner 32bit version;-)
 
@Keksi: Posteingang entleert ;)

@Roxxstar: Kann ich denn 2 verschiedene Java Versionen auf dem Rechner haben ?
Wenn ich das Java runterlade was mir Workbench empfiehlt, bekomme ich bei der Installation wieder dieses Virtual Machine Dingens. Und bricht damit quasi ab ... Trotzdem finde ich es dann in der Programm Liste :/ Aber richtig funktionieren tut es nicht ...
 

roxxstar

Gast
2verschiedene java versionen sollte nicht funktionieren, erst alte entfernen und dann die neue installieren

is aber schon paar monate her, dass ich workbench installiert habe, bin von daher nicht mehr richtig in der materie, habe auch einige Versuche gebraucht um die installation zum laufen zu bringen
 
Hab aktuell nur die neue drauf. (Java 8 64Bit)

Damit gehen so Sachen wie Minecraft usw. Nur Workbench meint ich hätte kein Java ...

greetz
 

MrKeksi

Gast
Sag mal wo bekommst du eigentlich Version 8 her? Ich habe nur 7 update 55 (Aktuell!) :p
 

DeletedUser61508

Gast
*einklink*

DS Workbench funktioniert nur mit 32-Bit Versionen von Java, bevorzugt die 7'er. Ob Java 8 funktioniert weiß ich nicht, sollte aber. Zwei Java-Installationen funktionieren nicht ohne Weiteres nebeneinander, aber Minecraft sollte auch 32-Bit vertragen.

---
Für alle die es interessiert, Problem ist nicht der Java-Teil von DS Workbench, sondern die Windows-Executable bzw. der Installer. Beide sind noch aus der Zeit wo ich selbst ein 32-Bit System hatte und 64-Bit noch die Ausnahme war, sind also auf 32-Bit zugeschnitten. Da das unter Linux/Mac keine Rolle spielt und selbst unter Windows auch 32-Bit immer noch problemlos unterstützt wird, hab ich in der Richtung nie etwas unternommen und erkläre lediglich von Zeit zu Zeit bei dem hier beschriebenen Problem wie es zu lösen ist. ;-)
 

MrKeksi

Gast

Wieso habe ich dann 2 Versionen? xD

---
btw: Huhu Torridity :p
 

DeletedUser61508

Gast

Wieso habe ich dann 2 Versionen? xD

---
btw: Huhu Torridity :p
Huhu! :)

Vielleicht weil du zu faul bist die alte Version zu deinstallieren? Ich hab hier 9 Versionen, angefangen von 1.4.2_19...kein Kommentar. ^^
Wobei ich bei dem Screenshot nun nicht 100%'ig sagen könnte was verwendet wird. Vermutlich hast du die Java 7 Update 55 als Letztes installiert oder gar getrennt von der JDK 7 Update 40 Version, weswegen die bevorzugt verwendet wird.
 

MrKeksi

Gast
Die 55 habe ich heute installiert xD
Und ja das kann gut möglich sein das die 64 Bit version von dem JDK kommt...
 
@Workbench Gott Toridity
Ich hab auch schon verschiedene 32er Bit Versionen probiert ... Gingen alle nicht.

Hab die 8er Version von Chip da ich ein 64Bit Java brauche. Gibt auch ein 7er Update 55, aber das klappt nicht.

Wenn ich mir die von WB vorgeschlagene Java Version runterlade, kommt ein Fehler und Wb klappt immer noch nicht ..
Wie soll ich so faken :D



greetz
 
Zuletzt bearbeitet:
Laut Google empfohlen, außerdem bekomme ich beim Installieren der 32er Bit Versionen jedesmal denselben Fehler beim Installieren ...

Hab Windows 7, Intel Core i5, Nvidia Grafikkarte, 64Bit System und 8Gb Ram, isn Laptop.

Bin nicht so ganz in der Materie, daher die paar Daten die vielleicht helfen können ...

greetz
 

FalkenaugeMihawk

Gast
Laut Google empfohlen, außerdem bekomme ich beim Installieren der 32er Bit Versionen jedesmal denselben Fehler beim Installieren ...

Hab Windows 7, Intel Core i5, Nvidia Grafikkarte, 64Bit System und 8Gb Ram, isn Laptop.

Bin nicht so ganz in der Materie, daher die paar Daten die vielleicht helfen können ...

greetz
Nur so als Geheimtipp, man kann auch auf einem 64bit System 32bit Programme installieren, sonst würde die Hälfte aller Programme gar nicht auf einem 64bit System funktionieren.
 

DeletedUser61508

Gast
Laut Google empfohlen, außerdem bekomme ich beim Installieren der 32er Bit Versionen jedesmal denselben Fehler beim Installieren ...

Hab Windows 7, Intel Core i5, Nvidia Grafikkarte, 64Bit System und 8Gb Ram, isn Laptop.

Bin nicht so ganz in der Materie, daher die paar Daten die vielleicht helfen können ...

greetz
Google lügt. ^^
Interessant wäre, welchen Fehler du bekommst. An deinem System scheint erstmal nix verkehrt zu sein. Was noch zu empfehlen ist wäre, alle Java Versionen zu deinstallieren bevor du eine Neue installierst.
 

DeletedUser61508

Gast
Hat ich oben schon erwähnt ... Kommt immer nur dieser Fehler: "Java could not create any virtual machine !"

greetz
Bei der Installation ist das sehr untypisch, da hilft der gepostete Link auch nicht weiter. Allerdings hat mich ein andere Beitrag auf eine mögliche Lösung gebracht. Hast du im Zusammenhang mit Minecraft irgendwann mal irgendwelche Umgebungsvariablen gesetzt die den Speicher für Java festlegen?
Du kannst mal unter Start -> Systemsteuerung -> System und Sicherheit -> System -> Erweiterte Systemeinstellungen -> Umgebungsvariablen (Button rechts unten) nachschauen. Such mal da nach oben erwähnten "_JAVA_OPTIONS" und poste den Wert hier, dann kann ich dir sagen ob es daran liegt und was du da eintragen musst damit es (möglicherweise) funktioniert.
 

DeletedUser61508

Gast
Weiß nicht was ihr macht, aber ich habe zwecks Testen unter Windows ~15 Versionen installiert...
Ja, wir sind hier aber nicht im Java- oder Programmiererforum. ;-)
Sagen wir so, für einen normalen Windows-Benutzer ist es nicht ohne Weiteres möglich, beliebig zwischen Java-Versionen zu wechseln.